En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 
 
 

Guppy 5.03 : Aide pour mettre son site à jour

GuppY : Pack GuppY 5.03, patchs cumulatif et non-cumulatif

ATTENTION ! Ces patchs ne concernent que les sites GUPPY en version 5 !  

Voici la 108 ème version de Guppy :  GuppY 5.03   (version minimale requise: PHP 5.6)

Guppy mis à jour avec le patch 5.03.00

Pour les sites Guppy en version 5.02.09

En téléchargement sur GuppyED :

ATTENTION ! A faire impérativement avant d'appliquer le patch Guppy ! :

1. Auparavant, il est recommandé de faire une sauvegarde complète de votre site.

2. Téléchargez sur votre ordinateur le patch gy-non-cumulative-50300.zip et passez au paragraphe suivant.


Comment mettre à jour votre site 5.02.09 vers 5.03.00 ?

Pour passer de la version 5.03, c'est le patch  nommé gy-non-cumulative-503.zip que vous devez utiliser.

 Méthode obligatoire. Avec la fonction Installer présente dans l'Administration de Guppy ainsi votre renommage anti-spam des fichiers sensibles est conservé.
 Se rendre dans la zone d'administration>> volet Administration Générale >> Installer.

  • Cliquez sur l'icône Installer.
  • Cliquez sur le bouton Parcourir pour sélectionner sur le disque dur de  votre ordinateur l'archive Zip du patch non cumulatif que vous venez de télécharger.
  • Le zip étant sélectionné, cliquez sur le bouton Charger le fichier. Guppy ouvre une page avec les détails de l'archive Zip.
  • Cliquez enfin sur Installer le fichier Zip.
  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.
  • Allez ensuite dans config look, puis compléter les nouvelles zones, puis cliquez sur  "Enregistrer la config", la feuille de style sera générée automatiquement
  • Allez ensuite dans config boites Web et Mobile, cliquez sur Enregistrer.
  • De même allez dans config Accueil Web et mobile, et cliquez sur Enregistrer.
  • Revenez sur la page d'accueil de votre site : Plusieurs rafraîchissements de la page peuvent être nécessaires.


Comment mettre à jour votre site inférieur à la version 5.02.09 ?

Pour passer d'une version 5.00.xx inférieure à la version 5.02.09, c'est le patch cumulatif 5.03.00 que vous devez utiliser : gy_upg_50300

Le patch cumulatif comporte toutes les corrections de  GuppY depuis  5.0.0.

ATTENTION ! A faire impérativement avant d'appliquer le patch de sécurité Guppy ! :

1. Auparavant, faites une sauvegarde complète de votre site.

2. Mettre à jour l'éditeur CK Editor vers la version 4.12.1 via la fonction Installer de Guppysi vous ne l'aviez pas déjà fait auparavant. En téléchargement ici sur Guppyed.

3. Appliquez le patch Addons for Guppy xxx. En téléchargement ici sur Guppyed.

4. Appliquez maintenant le patch de sécurité.

A noter :

  •  Vous devrez impérativement revalider toutes les pages de config après l'installation du patch cumulatif.


 Méthode obligatoireAvec la fonction "Installer" présente dans l'Administration de Guppy ainsi votre renommage anti-spam des fichiers sensibles est conservé.
 Se rendre dans la zone d'administration>>volet Administration Générale >> Installer.

  • Cliquez sur l'icône Installer.
  • Cliquez sur le bouton Parcourir pour sélectionner sur le disque dur de  votre ordinateur l'archive Zip du patch cumulatif que vous venez de télécharger.
  • Le zip étant sélectionné, cliquez sur le bouton Charger le fichier. Guppy ouvre une page avec les détails de l'archive Zip. (Attention votre hébergeur peut limiter la taille des fichiers téléchargeables- procédez alors avec la méthode 2)
  • Cliquez enfin sur Installer le fichier Zip.
  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.

  • Après application de ce patch
     
  • (dans le cas d'un Guppy inférieur à la version 5.0.2) :
    • lancez le script de mise à jour de l'index qui fait le lien entre les articles et les options de menu. Pour cela, tapez dans la barre d'adresse de votre navigateur : maj_index_arom.php à la suite de l'URL de votre site : http://www.monsite.net/ maj_index_arom.php.
    • Revalidez toutes les pages de config en commençant par Config Services puis Config générale.
    • Rappel : pour toutes les hauteurs des boites réglables, le calcul est en pixels, ne pas oublier de vérifier vos réglages dans config services.   
    • Pour vos skins : Après l'installation du patch avec la fonction Installer, vous devez aller en admin/config look, complétez la configuration des nouveaux champs de Config look, cliquez sur Enregistrer la config pour mettre à jour votre skin compatible Config look, ensuite plusieurs rafraîchissements de l'affichage d'une page peuvent être nécessaires pour avoir un affichage correct.

  • pour les sites supérieurs à 5.02 :
    • Allez en admin/config look. Cliquez sur Enregistrer la config
    • Validez les pages de configuration dans cet ordre : 1. Config boites WEB et Mobile, cliquez sur enregistrer de même pour les pages secondaires si vous en avez. .2 . Config Accueil/blog Web et Mobile, cliquez sur Enregistrer.
    • Vérifiez bien Config Boites, il se peut que certianes boites ne soient plus sélectionnées, elles ne s'afficheront donc plus, il faut simplement les remettre en place et cliquer sur Enregistrer.
    • Pour finir, validez chaque page de config.
    • Revenez sur l'accueil de votre site pour vérifier la place des boites et des menus. Il peut être nécessaire de rafarîchir la page en appuyant simultanément sur les 2 touches Contrl + F5.

Mehode par FTP : NON recommandée à cause de la non-conservation du renommage des fichiers sensibles et de la non-transformation du fichier skin.inc de chaque skin. Lors de l'application du patch cumulatif, il est prévu que le fichier skin.inc de chaque skin subisse une transformation (avec la méthode de mise à jour par la fonction Installer prévue dans Guppy). Si celle-ci n'a pas lieu, votre site ne s'affichera pas suite à une erreur. Au cas où et pour y remédier  : par FTP, il faudra charger dans chaque dossier skin de votre site, un fichier"neuf" skin.inc prélevé dans n'importe quel dossier skin dans l'archive .zip d'un  pack guppy V5.03.00.

Cas d'un Guppy < à  5.0.7

Si vous avez une version de GuppY inférieure à la 5.0.7, vous devez installer le patch cumulatif une seconde fois pour la prise en compte du renommage automatique des fichiers sensibles.

  • Puis procédez de même que décrit précédemment.

 


Merci à tous les participants à cette version de Guppy.

Lavachequireve 
- GuppyTeam


Catégorie : A ne pas manquer ! - Guppy Version 5.03
Page lue 123 fois

Skins Scolaires