En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
Recherche
 
Fermer

Nouveautés du site

(depuis 20 jours)

GuppY-Aide

Recherche

Recherche

Visites

 1529689 visiteurs

 6 visiteurs en ligne

Lettre d'information

Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.

Avant de soumettre ce formulaire, veuillez lire et accepter les Mentions légales.

J'accepte :
Recopier le code :
20 Abonnés

Préférences


Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe
<O>


Connectés :
( personne )
Snif !!!

Visites

 1529689 visiteurs

 6 visiteurs en ligne

Guppy 5.02.08 : Aide pour mettre son site à jour

rss Cet article est disponible en format standard RSS pour publication sur votre site web :
https://guppyed.eu/data/fr-articles.xml

GuppY : Pack GuppY 5.02.08, patchs cumulatif et non-cumulatif

ATTENTION ! Ces patchs ne concernent que les sites GUPPY en version 5 !  

Voici la 106ème version de Guppy :  GuppY 5.02.08    (version minimale requise: PHP 5.6)

Guppy mis à jour avec le patch 5.02.08

Pour les sites Guppy en version 5.02.06 et pour les sites Guppy en version 5.02.07 il faut utiliser le même patch ! Attention ! Pas pour les sites en version 5.02.05 !!! Dans ce dernier cas, reportez vous au paragraphe correspondant au bas de cet article.

En téléchargement sur GuppyED :

ATTENTION ! A faire impérativement avant d'appliquer le patch Guppy ! :

1. Auparavant, faites une sauvegarde complète de votre site.

2. Mettez à jour l'éditeur CK Editor vers la version 4.111 avec le patch via la fonction Installer de Guppy (voir procédure dans l'autre paragraphe)

3. Appliquez ensuite le patch Addons for GuppY 502XX à installer en admin avec la fonction Installer. Ce patch contient tous les addons nécessaires à GuppY 5.02.xx.

4. Téléchargez sur votre ordinateur le patch gy-non-cumulative-502058.zip et passez au paragraphe suivant.


Comment mettre à jour votre site 5.02.06 ou 5.02.07 vers 5.02.08 ?

Pour passer de la version 5.02.06 ou 5.02.07 à la version 5.02.08, c'est le patch  nommé gy-non-cumulative-502058.zip que vous devez utiliser.

2 Méthodes :

1. Méthode recommandée. Avec la fonction Installer présente dans l'Administration de Guppy ainsi votre renommage anti-spam des fichiers sensibles est conservé.
 Se rendre dans la zone d'administration>> volet Administration Générale >> Installer.

  • Cliquez sur l'icône Installer.
  • Cliquez sur le bouton Parcourir pour sélectionner sur le disque dur de  votre ordinateur l'archive Zip du patch non cumulatif que vous venez de télécharger.
  • Le zip étant sélectionné, cliquez sur le bouton Charger le fichier. Guppy ouvre une page avec les détails de l'archive Zip.
  • Cliquez enfin sur Installer le fichier Zip.
  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.
  • Allez ensuite dans config look, puis compléter les nouvelles zones, puis cliquez sur  "Enregistrer la config", la feuille de style sera générée automatiquement
  • Plusieurs rafraîchissements de la page peuvent être nécessaires.
  • Important ! Clé de sécurité : aller en Admin/Configuration Générale, cliquez sur Clé de Sécurité et "Générer une nouvelle clé de sécurité" puis sur "Enregistrer la config". Vous serez déconnecté comme membre, vous devez vous reconnecter en mettant votre pseudo et votre mot de passe.

2. Méthode par FTP si la fonction Installer n'est pas opérationnelle

  • Chargez par FTP, le contenu complet de chaque patch dans cet ordre (après avoir "dézippé" chaque archive.zip) :

 1.CKEditor  A charger en premier.

 2. Puis Addons for GupyXXX

3. Et enfin le patch gy-non-cumulative-502058

Ensuite :

  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.
  • Allez ensuite dans config look, puis compléter les nouvelles zones, puis cliquez sur  "Enregistrer la config", la feuille de style sera générée automatiquement
  • Plusieurs rafraîchissements de la page peuvent être nécessaires.
  • Important ! Clé de sécurité : aller en Admin/Configuration Générale, cliquez sur Clé de Sécurité et "Générer une nouvelle clé de sécurité" puis sur "Enregistrer la config". Vous serez déconnecté comme membre, vous devez vous reconnecter en mettant votre pseudo et votre mot de passe.


Comment mettre à jour votre site inférieur à la version 5.02.06 ?

Pour passer d'une version 5.00.xx inférieure à la version 5.02.06 vers la version 5.02.08, c'est le patch cumulatif 5.02.08 que vous devez utiliser : gy_upg_50208

Le patch cumulatif comporte toutes les corrections de  GuppY depuis  5.0.0.

ATTENTION ! A faire impérativement avant d'appliquer le patch de sécurité Guppy ! :

1. Auparavant, faites une sauvegarde complète de votre site.

2. Mettre à jour l'éditeur CK Editor vers la version 4.111 via la fonction Installer de Guppy (voir procédure dans l'autre paragraphe)

3. Appliquez le patch Addons for Guppy xxx.

4. Appliquez maintenant le patch de sécurité.

A noter :

  •  Vous devrez impérativement revalider toutes les pages de config après l'installation du patch cumulatif.

2 méthodes :


1. Méthode recommandée. Avec la fonction "Installer" présente dans l'Administration de Guppy ainsi votre renommage anti-spam des fichiers sensibles est conservé.
 Se rendre dans la zone d'administration>>volet Administration Générale >> Installer.

  • Cliquez sur l'icône Installer.
  • Cliquez sur le bouton Parcourir pour sélectionner sur le disque dur de  votre ordinateur l'archive Zip du patch cumulatif que vous venez de télécharger.
  • Le zip étant sélectionné, cliquez sur le bouton Charger le fichier. Guppy ouvre une page avec les détails de l'archive Zip. (Attention votre hébergeur peut limiter la taille des fichiers téléchargeables- procédez alors avec la méthode 2)
  • Cliquez enfin sur Installer le fichier Zip.
  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.
  • Après application de ce patch (dans le cas d'un Guppy inférieur à la version 5.0.2) : lancez le script de mise à jour de l'index qui fait le lien entre les articles et les options de menu. Pour cela, tapez dans la barre d'adresse de votre navigateur : maj_index_arom.php à la suite de l'URL de votre site : http://www.monsite.net/ maj_index_arom.php
  • Revalidez toutes les pages de config en commençant par Config Services puis Config générale.
  • Rappel : pour toutes les hauteurs des boites réglables, le calcul est en pixels, ne pas oublier de vérifier vos réglages dans config services.   
  • Pour vos skins : Après l'installation du patch avec la fonction Installer, vous devez aller en admin/config look, complétez la configuration des nouveaux champs de Config look, cliquez sur Enregistrer la config pour mettre à jour votre skin compatible Config look, ensuite plusieurs rafraîchissements de l'affichage d'une page peuvent être nécessaires pour avoir un affichage correct.

2. Méthode par FTP si la fonction Installer n'est pas opérationnelle

  • AVANT d'appliquer le patch !!! Remettez les noms des fichiers sensibles comme dans un Guppy d'origine.
    • Rendez-vous dans l'administration de votre site, cliquez sur l'onglet Configurations >> Config Services, puis à la ligne Contributions visiteurs & Spams, dans la partie Donner un autre nom aux scripts suivants (sans le .php), vos noms de fichiers sont activés (attention ! notez bien ces noms de "renommage" que vous aviez mis, il faudra les remettre après la procédure de mise à jour !)
    • il faut remettre les noms par défaut d'un Guppy d'origine. Procédure très simple et rapide, il suffit de vider tous les champs et d'enregistrer. Les fichiers sont renommés par défaut comme à l'origine. 
    • Laisser la page du navigateur ouverte pour valider les pages config après la mise a jour.
  • Chargez par FTP, le contenu complet du patch cumulatif 5.02.08
  • Mise à jour du nouvel index pour les sites en version 5.0.2 : après avoir appliqué ce patch, lancez le script de mise à jour du nouvel index qui fait le lien entre articles et options de menu.  Pour cela, dans la barre d'adresse de votre navigateur tapez maj_index_arom.php à la suite de l'URL de votre site : http://www.monsite.net/ maj_index_arom.php
  • Allez dans l'administration pour reconfigurer les pages admin comme vous les aviez auparavant : d'abord config Services puis config générale.
  • Rappel : pour toutes les hauteurs des boites réglables, le calcul est en pixels, ne pas oublier de vérifier vos réglages dans config services.   
  • APRES avoir appliqué le patch : Renommage des fichiers avec vos noms à vous : Revenir dans la zone d'administration et renommez les fichiers sensibles avec le même nom que vous aviez choisi avant l'application du patch.
  • Pour vos skins : La skin no_skin est opérationnelle. Si vous rencontrez des problèmes d'affichage avec votre skin d'origine (skin active), exécutez le fichier maj_configmob.php en l'ajoutant à l'url de votre site : http://www.monsite.net/maj_configmob.php puis rafraîchir la page pour avoir l'affichage correct (appuyez simultanément sur les 2 touches Ctrl  F5). Pour les autres skins utilisées vous devez sélectionner les skins une par une en skin d'origine (skin active) et exécuter le fichier maj_configmob.php et rafraîchir la page comme précédemment.

Cas d'un Guppy < à  5.0.7

Si vous avez une version de GuppY inférieure à la 5.0.7, vous devez installer le patch cumulatif une seconde fois pour la prise en compte du renommage automatique des fichiers sensibles.

  • Puis procédez de même que décrit précédemment.

 Les skins du pack Guppy Ecole sont adaptées pour l'utilisation en mode "responsive" et à l'utilisation de "Config Look"


Merci à tous les participants à cette version de Guppy.

Lavachequireve 
- GuppyTeam


Catégorie : A ne pas manquer ! - Guppy Version 5.02
Page lue 58 fois

Vous êtes ici :   Accueil » Guppy 5.02.08 : Aide pour mettre son site à jour

 Hébergement LWS

Ce site respecte la charte de l'anneau Sitinstit